[Rock-dev] Replacement for base::actuators::MotorState

Janosch Machowinski Janosch.Machowinski at dfki.de
Tue Feb 19 13:16:20 CET 2013


On 19.02.2013 11:20, Sylvain Joyeux wrote:
>>
>>           ///Encoder at the motor shaft
>>           Encoder motorShaftEncoder;
>>
>>           ///Encoder at the output side
>>           ///e.g. behind the gearbox
>>           Encoder ouputSideEncoder;
> And what about cases where there are more than two encoders ? This 
> encoder thing was the very reason that we wanted a bigger discussion.
I would prefer to not use a dynamic data structure here. But one thing 
one could do is :

enum ENCOODER_POSITION
{
     POSITION_MOTOR_SHAFT,
     POSITION_OUTPUT_SIDE,
     .
     .
     .
};

and use an std::vector<Encoder>.
In general I am not too happy with the encoder type. It would be nice to
have distinct absolute/incremental encoders.
>
> I would personally prefer splitting the actuator from the encoders and 
> have a way to describe a "chain" of actuators / encoders. KDL was a 
> candidate, at that point, to provide the required data structures.
I don't think that KDL will work for this use case as it is not a chain 
of encoders. We have multiple
encoders measuring (more or less) the same thing. Also there is no 
primitive 'encoder' in KDL.
KDL looks more suited for frame transformation representation.
Greetings
     Janosch


-- 
  Dipl. Inf. Janosch Machowinski
  SAR- & Sicherheitsrobotik

  Universität Bremen
  FB 3 - Mathematik und Informatik
  AG Robotik
  Robert-Hooke-Straße 5
  28359 Bremen, Germany

  Tel.:     +49 421 178 45-6614
  Zentrale: +49 421 178 45-6611
  Fax:      +49 421 178 45-4150
  E-Mail:   jmachowinski at informatik.uni-bremen.de

  Weitere Informationen: http://www.informatik.uni-bremen.de/robotik



More information about the Rock-dev mailing list