[Rock-dev] base::Angle

Jakob Schwendner jakob.schwendner at dfki.de
Fri Apr 12 12:02:57 CEST 2013


opposite() I also like better than invert().

cheers,

Jakob

On April 12, 2013 at 11:58 AM Felix Rehrmann <felix.rehrmann at dfki.de> wrote:
> Hi,
>
> if I understand the invert function correctly I would prefer to call it
> opposite or oppositeDirection (inversion sounds somehow strange with
> regard to angles).
>
> Felix
>
> Am 12.04.2013 11:48, schrieb Janosch Machowinski:
> > Hey,
> > I want to extend base::Angle by two methods but I am not
> > sure about the naming of the methods.
> >
> > One would be :
> > /**
> > * Inverts the current angle
> > * */
> > inline Angle &invert()
> > {
> > if(rad < 0)
> > rad += M_PI;
> > else
> > rad -=M_PI;
> > return *this;
> > }
> >
> >
> > The other would be :
> > Angle operator-()
> > {
> > rad = -rad;
> > }
> >
> > Is this an correct intuitive naming scheme ?
> > Better ideas ?
> > Greetings
> > Janosch
> >
> >
> > _______________________________________________
> > Rock-dev mailing list
> > Rock-dev at dfki.de
> > http://www.dfki.de/mailman/cgi-bin/listinfo/rock-dev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.dfki.de/pipermail/rock-dev/attachments/20130412/f1c3ae78/attachment.htm 


More information about the Rock-dev mailing list